M1 Support Forum Zone Trigger (zt) Command Reply To: Zone Trigger (zt) Command

Martin Banks

    Hi Jay, Brad et al.

    I’ve had some success today with zt.  Here’s what worked:

    – Brad sent me a firmware update overnight to 5.2.39.  Was previously running 5.3.10.

    – I ran a series of tests across various vacant Inputs, with combinations of physical jumpers and open circuits, then tested by pulsing the zt command using the approved syntax.  I used the Ness SDK software to generate the strings.  I assume there is an Elk branded version of this software too.  The generated strings agreed with the Protocol document and I checked the checksums with an Online Checksum Calculator.  For example for Input 48, I used the string:  09zt04800AD\r.

    – Command has no effect on inputs without a physical jumper.

    – Command only worked for me on Zone Type “1 = Normally Closed”.  Therefore has no effect on Zone Definition “00 = Disabled”.

    – On pulsing the command, the Input would stay Open/Violated for different times according to the Zone Definition.

    – “01 = Burglar Entry/Exit 1” stayed violated for roughly 32s

    – “04 = Burglar Interior” stayed violated for roughly 32s

    – “16 = Non-alarm” stayed violated for roughly 46s


    So, we have success and can use the command going forward for M1 responses triggered by Crestron, such as Crestron PIRs and digital triggers from security cameras.

    Thanks Brad and Jay for your help.

    Scroll to Top