Reply To: ELK C1M1 – Any restrictions in terms of M1 firmware version?

M1 Support Forum ELK C1M1 – Any restrictions in terms of M1 firmware version? Reply To: ELK C1M1 – Any restrictions in terms of M1 firmware version?

#4516
ELK Tech Support

To be compliant and fully compatible with the ELK C1M1 Communicator the ELK M1 Control should be running Firmware 5.3.10 or later.

Scroll to Top