M1 Support Forum Error on ELKRP2 startup after update

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #5662
    Mike Morris


      After updating ElkRP from v2.0.20 to 2.0.40, the following now occurs attempting to open an account after startup:

      “The controls database is out of date. An update is available. Do you want to update it now?”
      Clicking “Yes” results in: “Unable to open the temporary database, possibly because there was a disk drive error.”
      Responding “OK” to acknowledge the error message results in the first message repeating.  After three cycles of “Yes” and “OK”, the error does not recur.

      Closing and reopening the account (or restarting ElkRP) results in the same error sequence as above.
      There are no error messages listed in the ElkRPLog2.txt file.

      No issues previously with v2.0.20.

      Any ideas?


      Brad Weeks

        Close the ElkRP2 Software and from Windows Add/Remove Programs,  select RP, select Remove and you should be prompted to Remove, Modifier or Repair and select “Repair”. Once the Repair is complete reboot your PC and try opening ElKRP2 to see if you receive the same error message

        Mike Robles



          I have the same issue. The repair did not work. What else can I try?





          Brad Weeks

            Completely Uninstall search the local c drive for the RP folder and if found delete then try a fresh new install.

            Mike Robles


              Thanks for the reply. What will happen to my systems if I delete the app and its data?

              Brad Weeks

                Make a copy of the elkaccts2.mdb file which will be all of your RP2 Accounts


                  I just got around to updating RP2 from 2.0.24 to 2.0.40, same as the thread originator. Ran into the same issue…..”Controls database out of date.” with the same three repeats and same “drive error”.

                  Re-installing RP2 did not fix it. If I ignore the errors, I can still connect and everything looks fine.


                  Is this something to worry about? The repeating error message are annoying though.


                    No Worries….Problem solved.

                    Since I was at a loss on what to do about those errors, I took a new approach, actually two. The first did not work, but the second did.

                    1. I tried to export the account from RP 2.0.24, and then import it into 2.0.40. I was bombarded with errors, so I abandoned that.

                    2. I created a new account in RP 2.0.40, connected to the M1, and uploaded all of the configuration from the M1. It took two connections before everything was captured (strange?). It looks all OK. I did have to re-type all of my comments in the rules, but that only took about 10 minutes.

                    It seems OK now.

                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.
                  Scroll to Top