M1 Support Forum m1xep fails to get m1cloud id – connection required


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #6223
    steve McCormick

      HI all,

      I’m trying to use the “obtain account id” function of the m1xep so that I can use remote control of my m1 panel.  When I hit the button it throws an error “connection required”, “to obtain an m1cloud id for this account you must be connected to the system via a network connection”.  This occurs with a connection established.


      This error seems to refer to a connection between the m1 and elkrp, so I disabled desktop firewall and antivirus, no change.  I have also reviewed my firewall settings on the edge router (usg) and can find no restrictions that would block elkrp or the m1 from routing outside my network.

      I have installed that latest bootloader and firmware for the m1xep and the latest elkrp software.

      The panel has been operating fine for about 10 years.  I can connect elkrp to the panel via network connection and configure as I anything I would like and view status.


      Any help would be appreciated,


      Brad Weeks

        In the M1XEP setup under the TCP/IP Setting tab make sure you’ve entered a valid Primary DNS Server IP address. In some cases you can use the the Default Gateway IP as your Primary DNS Server and make sure this setting is sent to the M1XEP.

        Ernie Quintana

          How do I ubtain a m1cloud id for an M1 Gold on a network?

          Brad Weeks

            M1 Cloud ID is only required if wanting to use apps or services from Planet M1 or Connect ONE. To obtain the M1 Cloud ID connect to the system using ElkRP2 click the M1XEP Setup make sure you have a valid Primary DNS Server IP then click the M1 Cloud tab and follow the prompts.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.
          Scroll to Top