Controlling a somfy shade

M1 Support Forum Controlling a somfy shade

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5282
    Paul Cozzolino

    I am having trouble connecting my M1XSP to a somfy shade.  Here is the backstory.  I purchased a M1XSP and a URTS II interface to control somfy shades.  I have successfully registered my unit and made sure the baud rate is at 9600 to talk to the somfy unit.  My command into the Elk system is “When F4 on the keypad is pressed then send the following text “0103U”  I have tried sending it with the <cr> and without.  I have also set the jumper to RS232.  The URTS came with an RJ485/DB9 adapter which I plugged in and still did not get a signal to the unit.  I have tried creating my own serial cable by installing a LAN Connector to the ELD-406A cable and have tried every combination on pins 2,3 and 5.  I according to the URTSII manual I needed to put the RX into position 3 the TX into position 6 and the ground into position 8 in the LAN input.

    My questions are obviously what am I missing?

    Am I supposed to measure a signal when I press F4 on pins 2 and 5 on the M1XSP?  I am not sure on how a DB9 serial port works but I assume its like any other electrical circuit.

     

    #5283
    Brad Weeks

    You configured the M1XSP for generic serial port expander with the default firmware? What is the address for the M1XSP? In your rule you need to specify the Port to send out the string and the Port needs to match the address for the M1XSP.

    #5286
    Paul Cozzolino

    sorry I got lazy on my typing out the command.  The M1XSP has an address of 01 and the rest of the command is that it is going out through port 1.  I am currently using the standard firmware for this serial port

    #5301
    Brad Weeks

    Please make sure your pinout is:

    PIN 3 wire to M1XSP DB9 Pin 2.

    PIN 6 wire to M1XSP DB9 Pin 3.

    PIN 8 wire to M1XSP DB9 Pin 5.

    #5303
    Paul Cozzolino

    Thanks Brad.  I figured out the issue that it wasn’t in the elk system side it was the configuration of the somfy shade along.  The installation manual on their end didn’t clearly explain how the communication happens.  For all of those that may read this post you have to rotate the selector switch initially to program the shade.  However, when it is communicating with the M1XSP the selector switch has to be put back to what the address is.  In this case the text string of 0103U which I used, the address is 01 and the channel is 03.  So I need to change the selector switch back to 01 to have it communicate with the elk system.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Scroll to Top