M1 Support Forum Elk M1 app Password with Gmail or Yahoo

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #6331

      Earlier this year, Elk products sent out a memo in reference email providers increasing security for their email platforms, and recommended setting up a specific app password for Elk M1 systems…  I successfully did that for Gmail, but am noticing my email communications I had setup through my M1XEP which were almost instantaneous, are now delayed by hours and sometimes days… This makes this communications now useless, especially if I am trying to communicate an AC Power or security issue.  I believe Gmail is having issues quickly communicating to Verizon text, either vtext or vzw….  Am I missing something in this setup?

      I even tried to use yahoo’s app password setup but couldn’t find the correct Elk app name to set this up.

      Any thoughts?

      Brad Weeks

        The Email feature of the M1XEP is intended for automation purposes and not as a means communicating life safety or critical events. For those situations it is recommended to have the M1 report the condition to a central monitoring services and let them dispatch the appropriate authorities or notify individuals provided the central station offers that service. When the rule fires to send the email message the message is set at that time and any delays caused by the email provider or exchange server are beyond our control.

        Eric Bailey


          I know this isn’t a solution, but I found a workaround to your issue.

          I am having the same problem, with what it sounds like a similar setup to you.  Emails sent to [mobile number]@vtext.com from the gmail information I have in the MX1EP don’t seem to go through from my Elk system.  Even directly sending an email directly from the Gmail account to the vtext.com email address don’t go through either.  So it must be an issue, like you said, between Gmail and Verizon.

          How I ended up getting something to work is changing all the “[mobile number]@vtext.com” in the 2nd column for email messages 1-16, to [my gmail username]@gmail.com.  Basically, putting the same information in the from, user name, and email address fields in the email tab of the MX1EP Setup box.  What you end up doing it sending an email to yourself.  Now, I have a dedicated Gmail address for my Elk, so the only thing that uses that Gmail address is the MX1EP, and depending on your phone, you may be able to make a unique notification sound for incoming emails from that Gmail account only (my Samsung allowed me to do that).  So if you don’t have a dedicated email address for that, you might want to set yourself up one to isolate it out. The only disadvantage I can see (again, may be depending on your phone’s settings) is that preview on my phone only shows I received an email and just shows the subject “Alert from M1”.  I have to open the email to see the message the panel is sending me.

          Hope that helps and if you have any questions, let me know!



            Thank you for your response. I totally understand your position, but in my very rural environment, I can respond quicker than the first responders.


            I have had a dedicated email address for my two M1 systems, and had setup rules for a daily ‘heartbeat’ to be sent to those email addresses for the past 12 years. This basically tells me my M1 communication systems are still up and running. These emails are almost instantaneous, but understand, as Brad has stated, they are dependent on the email servers… I have changed my 1-16 M1 email messages to now communicate to those email addresses instead of trying to communicate directly to our phones via text, when I found out that Verizon text communications were not working through gmail in a timely manner, and there really is no such work around in gmail or yahoo….  These have been working great…

            Thanks for the feedback…

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.
          Scroll to Top