Elk-M1XEP Interface Documentation/Example

M1 Support Forum Elk-M1XEP Interface Documentation/Example

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #5094
    Matthew Uberecken

    I have had a custom service connecting to my Elk M1 via serial port working for some time.  I recently bought the M1XEP to allow some changes in my home network environment.  I can connect to the unencrypted port via TCP (with no login enabled) and things seem to work as before.  The instructions (and best practices) suggest that I should be using both encryption (TLS) and auth credentials.

    I could not find any documentation of the auth protocol – please help.

    I also could not get the TLS connection working.  I have the updated Elk-M1XEP firmware.  I have tried with both the DotNet TcpClient/SslStream as well as the C++ boost::asio::ssl library, both of which I have quite a bit of experience with.  I have tried custom certificate validation and various explicit levels of SSL/TLS to no avail.

    Is there any documentation on this protocol and/or are there any examples?

    #5238
    Glenn Waters

    There’s some Python code here that I wrote: https://github.com/gwww/elkm1

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Scroll to Top