ELKM1PCSPIM output not controlling UPB devices

M1 Support Forum ELKM1PCSPIM output not controlling UPB devices

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #5930
    Martin Multer

    Brand New M1G and PIM-E bench testing in perfect environment two rules, one to turn on a lighting device (outlet) and another rule to turn the same device off at set times.  When the rules instruct the UPB device to turn on or off the red LED on the UPB Interface “PIM-E” comes on briefly, but the device I am trying to turn on does not come on or go off from this PIM-E.  I can turn the device on or off using Up Start or a controller with buttons I have programmed for this bench test.

    Using the Up Start “tools” signals look perfect with no noise regardless of where the signals are coming from in this case the PIM-E or the external controller.  I have the “format” in “Lighting of the M1 G set for “Serial Expander”.

    I don’t have a UPB character signal grabber so I can’t determine what exactly the PIM-E is sending out so I don’t know if I have a bad PIM-E, missing a step somewhere, or a module to make it all work with UPB.

    #5931
    Brad Weeks

    In ElkRP2 under Globals G29 – G42 make sure the UPB Lighting Address matches the information in UpStart. Under the Automation and Lighting right-click on Lighting, click Import Lighting Data, select the UPB Upstart and import the UpStart UPE file. Once imported into ElKRP2 for each device the Format should be Serial Port Expander, and the OPT option should NOT be checked. Make sure to send this information to the M1 and retest.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Scroll to Top