Failure updating to firmware M1G_5.3.14

M1 Support Forum Failure updating to firmware M1G_5.3.14

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6453
    Gordon Larsen

    I am having trouble updating my M1G to M1G_5.3.14.  The update erased the EEPROM, and all attempts to reprogram fail.  The failures occur at different points in the process each time, sometimes at 1%, sometimes at 95%.  I have tried both secure and non-secure connections to the M1XEP, two different PCs, both running RP 2.0.40.  Boot firmware is at 3.3.6, on hardware 0.13.  Previous firmware level was 5.3.10

    The error is: “Error programming flash memory.  System may not operate unless flash programming is successfully completed”

    I have also tried resetting power on both the M1G and the M1XEP to no avail.  Anyone have any suggestions as to what a resolution may be?

    #6454
    Brad Weeks

    Use a direct USB to RS232 Serial connection to the M1 and try updating the Firmware.

    #6455
    Gordon Larsen

    Thanks.  Actually, I found the issue to be a flaky wi-fi adapter on my laptop.  Switched to a wired connection and problem resolved.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Scroll to Top