gmail is blocking M1 emails

M1 Support Forum gmail is blocking M1 emails

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5393
    Malcolm Johnson

    I am trying to set up emails sent from M1 to my gmail account.  When I test I find that they don’t go through but I get a warning saying that an attempt was made to access my account from a less secure site.  I then set gmail to allow access to less secure accounts and then the emails came through.  However I don’t want to keep that setting in gmail against their security warning.  I just updated all of my firmware and software to the latest M1 and RP2 versions.

    #5703
    Jerry Galu

    I had a similar problem had to research what port would work. I found that 465 and server address http://smtp.gmail.com with your user name (email). My only issue with using gmail is it sometimes delays the notification so looking for some other free service.

    #5733
    Malcolm Johnson

    Jerry, Thanks for the reply.  However I have been using 465 and that gmail smpt.  An email gets set to my gmail address but I can’t open it.  Google send me the following message:

     

    Someone just used your password to try to sign in to your account from a non-Google app. Google blocked them, but you should check what happened. Review your account activity to make sure no one else has access.

     

    If I change the google settings to allow non secure emails, which Google doesn’t recommend, then the emails do come through but I don’t want to leave that setting.

    #5740
    Bruce Cowan

    I use gmail with no issues

    here is my configuration using elkRP2 application:

    1) select “M1XEP Setup” from the top level page

    2)under the “TCP/IP” tab
    specify the DNS addresses (to resolve “smtp.gmail.com” set in the next step)
    enter your ISP’s primary and secondary DNS server IP’s
    secure port: 2601

    3) under the “Email” tab
    Server URL/IP address: smtp.gmail.com
    “From” email address: your email@gmail.com
    Port: 465
    Username: your gmail account user name
    Password: your gmail account password
    enter email messages in boxes below

     

    #5741
    Bruce Cowan

    I believe the message you received from Google is just a warning.

    was there any option for you to approve the access from the “non-Goggle app”?

    #5742
    Bruce Cowan

    and I should add that I have enabled access from “non-Google” apps.   part of the risk I suppose

    I only use a specific gmail account for M1 messaging and use a very secure password

     

    #5746
    Malcolm Johnson

    Bruce,

    Thanks for the tip.  I think  you have the solution for me.  I had set up M1 as you described and I did approve access to non-google apps.  When I did that, the emails came through to my account.  But I changed that access because of the warning.  I will set up a separate gmail account and send them from that instead to see how that works

    Mal Johnson

    #5799
    MKG

    There is a better and secure way to give non-Google apps “SMTP access” to the Google account. You can generate an “app password” and use that in ELK. It works as follows:

    1. Sign in to your Gmail account security
    2. Enable 2-step verification.
    3. Create an App password
    4. Use this password for SMTP.

    The process to generate and use app password is documented here:

    https://support.google.com/mail/answer/185833?hl=en-GB

    App password works with ELK. It is very secure. Also, it only allows SMTP access to the Google account and NOT the complete access to Gmail/Google account.
    Another problem in using “Allow less secure apps” option is that this option get disabled after some time, auto-magically. Unless you check, you don’t know that this option has been disabled.

     

    #5798
    MKG

    There is much better/secure way to allow non-Google apps (like ELK) to send emails using a Google account. You can define an “app password” and use that in ELK. The “app password” is auto-generated by Google and it contains 16 chars. There is no need open your gmail account to potential hacking. App password is very secure.

    I am using app password with ELK. The process to define app password is defined here:

    https://support.google.com/mail/answer/185833?hl=en-GB

    Hope it helps!
    MKG

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Scroll to Top