HAI Omnistat

M1 Support Forum HAI Omnistat

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #4417
    M1 Installer

    Lightening fried one of two Omnistats (for multistage heat pumps). To replace it appears I will have to replace the dead Omnistat (Model 100 V1.6) with an Omnistat2 as Leviton no longer produces the HAI Omnistat. Consider the different baud rates (300 vs 2400) as noted in the ELK-M1XSP install doc, can I have both an Omnistat and Omnistat2 on the same implementation or must both to be upgraded to Omnistat2’s?

    Thanks.

    Steve H.

    #4523
    ELK Tech Support

    M1XSP Firmware Update 70.0.2 should work with both OmniStat RC and OmniStat 2 Series of Thermostats. Because you’ll have both you’ll need to set the Baud/Communication Rate to 300. See the “Supplementary Instructions and Release Notes for M1XSP Special Firmware Versions” for more information.

    #5567
    Marc Robinson

    <span class=”VIiyi” lang=”en”><span class=”JLqJ4b ChMk0b” data-language-for-alternatives=”en” data-language-to-translate-into=”fr” data-phrase-index=”0″>Hello</span> </span>

    <span class=”VIiyi” lang=”en”><span class=”JLqJ4b ChMk0b” data-language-for-alternatives=”en” data-language-to-translate-into=”fr” data-phrase-index=”2″>Why is it written in the ELK-M1XSP Manual Installation document on page 5 that with an HAI Omnistat Series 2 thermostat that the baud rate is 2400?</span> <span class=”JLqJ4b ChMk0b” data-language-for-alternatives=”en” data-language-to-translate-into=”fr” data-phrase-index=”4″>I currently have a communication problem with the OmniStat2 thermostat that I cannot resolve.</span></span>

     

    Marc

    #5590
    Brad Weeks

    Make sure the Omni Stat address is set to 1 and and the M1XSP running Firmware 7.x.x  is set to address 1 as well. There should be two location within the Omni programming to set the Baud Rate make sure both are set the same. You can try 2400 Baud Rate to start with but may need to lower to 300 (make sure Omni and the M1XSP are set to the same baud rate)

    #5649
    Marc Robinson

    I finally managed to turn on the communication with the thermostat. I don’t understand, this happened on its own two days after several tries that didn’t work. It lasted a week, everything was working fine. I saw the temperature of the thermostat with the M1PNAV and I had access through the Ekepad application. My comfort and economy modes were working in the good morning and good evening tasks. But since I put the cover back on the M1XSP, I have no more communication with it. At school, I have two in test and they do not communicate with their respective M1.

     

    I do not know what to do.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Scroll to Top