Is my XEP in need of repair?

M1 Support Forum Is my XEP in need of repair?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5056
    Mark

    I can connect well via Serial, but the connection through RP is spotty at best.  After several attempts, it will sometimes connect, but only for a short while.  The connection will then terminate.  While in, data transfer is VERY choppy and slow.

    Is there a diagnostic process I can perform to isolate the issue?

    #5060
    Brad Weeks

    What is the Firmware in the M1XEP and what version of ElkRP2 are you running? Does the keypad or M1 LOG indicate “Ethernet Trouble” ?

    #5061
    Mark

    Mr. Weeks, it is good to see that you are still around helping people.  Thank you for your reply.

    I apologize — I should have included at least that much information in my initial post.

    • M1 XEP Firmware is 2.0.46
    • ElkRP2 Version 2.0.40
    • The only instances of “Ethernet Trouble” in the log are related to loss of power at the house.

    In the category of “I don’t know if this helps or not,”

    • We also run HomeSeer (with the Elk Plugin), and there are numerous communication errors there.  They are all related to “no response/improper response” to various cv#### commands.
    • We also use M1 Touch Pro apps on our phones and connectivity there is very very spotty as well.
    • Again, a direct Serial connection is flawless (as always).

    Let me know of any further information that you may need…..thanks!

    #5062
    Mark

    Just tried pinging the unit:

    188 packets transmitted, 48 received, 74.4681% packet loss, time 190933ms
    rtt min/avg/max/mdev = 0.829/218.317/3171.173/679.136 ms, pipe 4
    #5064
    Brad Weeks

    Have you enabled the Non-Secure Port 2101 and directed HomeSeer to connect on Port 2101? In ElkRP2 version 2.0.40 click the M1XEP Setup, click Trace, click Select All, click Show Setup, click Resume, Connect to the the system. Allow the trace to run for several minutes then click copy to clipboard, paste into an email and forward to techsupport@elkproducts.com with a note.

    #5078
    Mark

    Evening Brad,

    Yes, the non-secure port has always been enabled and HomeSeer is configured correctly.  It has typically worked well.  I’m not terribly concerned about those nuisance errors at the moment.  I’m mostly concerned about the recent inability to reliably connect remotely (or even locally).  This was all brought to light during a recent wind event that blew open an unsecured door and we were unable to silence the alarm from work.  I’m sure the neighbors were not pleased.

    As of yet, I have been unable to quickly and easily connect to the system to run your requested trace.  I have temporarily disconnected the XEP from our network as I found it was creating creating issues with my wife’s work laptop (her latency disappeared once I removed the XEP connection).  I will make a more concerted effort to connect and forward the results over the weekend….thanks!

    #5080
    Marcus Krumpholz

    Mark:

    I’ll defer to Brad officially.

    The ping tests high rate of failure is concerning. That should not happen.

    Does the XEP have a static or DHCP address? Does the XEP and your wife’s computer by chance have the same IP address? If so, then that could possible cause similar symptom. Not likely but it can. In this case the two network adapters are both trying to connect into the network which causes problems.

    You could set up and connect the XEP into a standalone network switch and then use another computer (that is also temporarily connected to this switch) to ping the XEP interface. If the ping response drops packets like before then it is possible that the XEP needs further investigation. If everything works then you have further insights that maybe the XEP does work fine.  It could be a switch port or cable as well. Take that into consideration as part of your troubleshooting.

     

    #5081
    Mark

    Thanks, Marcus.  I like that idea and will likely add it to my troubleshooting list once I’ve completed Brad’s request.  I do have an extra switch.  I have already swapped ports (even switches) and cables.  The XEP does have its own static address (I had the same initial thought).  I think I’ve picked all the low-hanging fruit.

    #5086
    Mark

    I emailed a couple traces to tech support. Unfortunately, the system disconnects after only a minute or three (this is why I included more than one trace), so I hope that it includes some meaningful data.

    #5101
    Mark

    On Brad’s instruction, I disconnected everything from the network, leaving only a laptop (for ElkRP2 use with a wired connection) and the XEP.  Elk RP2 connected well and stayed connected.  I then brought each device back on the network one at a time starting with wireless, as I considered those more unlikely to be the cause of any network disruption.  I paused between devices, monitoring the connection between the laptop and the XEP.  It remained stable.  I then did the same with the wired connections, but stopped when I had connected all my known/labeled cables.  The connection remained solid.  I now suspect a bad cable or connection on one or more of my unused runs.

    New ping data looks great…

    Packets: Sent = 10, Received = 10, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 4ms, Average = 3ms

    I consider this resolved.  Thanks, All!

     

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
Scroll to Top