m1xep killed by firmware update??

M1 Support Forum m1xep killed by firmware update??

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #6226
    steve McCormick

    HI all,

    For reasons irrelevant to this issue I recently updated the bootloader and firmware on an installed m1xep ethernet adapter.  After updating and rebooting I was able to access the m1 with rp.  After making some configuration changes to the xep and rebooting, rp no longer connected.  I discovered at this point that the xep ip address had changed to the default.  Changed PC ip to same subnet and reconfigured the xep ip address (static).  Now the xep won’t save the new data.  I then used the JP2 to reconfigure the xep to use dhcp.  The xep would not get a lease from my dhcp server.  Yes, the dhcp server is up and operational, some 20 devices use it daily.

    At this point I go the update firmware function and try to rerun the installation.  Now that errors with “version cannot be upgraded”, “bootloader software version erased”.

    Is there anyway to recover from this?  Did I just flush $300?

    Any help is appreciated,

    Steve

    #6227
    Brad Weeks

    On the M1XEP Setup window click Find and after finding the M1XEP on the LAN is the “PGM Firmware” button grayed out” If not click PGM Firmware to see if you’re able to reload the firmware.

    #6228
    steve McCormick

    Brad, Thanks for the response ,

    The “pgm firmware” button is disabled.  I switched my pc over to the same subnet with the same results.

    Is there anything more I can try?

     

    Steve

    #6229
    Brad Weeks

    Try running the Special M1XEP 2.0.34 Updater Utility https://www.elkproducts.com/elk-m1xep-and-windows-compatibility/

    #6232
    steve McCormick

    Tried the special updater, it errored with a version incompatibility message too.

    Hopefully there are other avenues??

    #6236
    steve McCormick

    Hey brad, any other possible solutions to this issue?

    #6238
    steve McCormick

    Brad I just tried to respond to your email but received this error:

     

    Technical details of permanent failure:
    554.5.7.1 The user or domain that you are sending to (or from) has a policy that
    554.5.7.1 prohibited the mail that you sent. Please contact your domain
    554.5.7.1 administrator for further details. For more information, please visit
    554.5.7.1 http://support.google.com/a/answer/172179

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Scroll to Top