Cannot connect to ELK M1

M1 Support Forum Cannot connect to ELK M1

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4907
    Trevor Jackson

    Hi, I am having issues connecting to my ELK M1.  I’ve tried connecting via the M1EXP, which I can reach however when trying to connect to the controller over the network, the ELK RP software returns the message: “System returned invalid information”.

     

    I also tried connecting locally from a different system using 2 different USB to Serial adapters and the system returns the message “System did not respond. Cannot detect baud rate setting”.

    I have confirmed that my baud rate is set to 11500 but still that doesn’t seem to change anything.

    Just to eliminate any issues with the USB to Serial adapter, I also connected it to another system using a legacy serial port and I receive the same message.

    Any suggestions on how to fix this problem or to verify that the serial port on my M1 is still good?

    Thanks.

     

    #4910
    Brad Weeks

    Through Keypad Programming Menu 9-Installation Programming, 07-Globals System Definitions, G34 should be set to G34: 9 = 115200 Serial Port 0 Baud Rate. What version of ElkRP2 Programming Software are you running? If not running ElkRP2 version 2.0.38  I would suggest updating. Have you verified using the “Special M1XEP 2.0.34 Updater Utility” https://www.elkproducts.com/elk-m1xep-and-windows-compatibility/ the M1XEP is running Firmware 2.0.34 or higher?

     

    For the Serial Connection under Windows, Device Manager, Ports (COM & LPT) what COM Port number has Windows assigned? In ElkRP2 under Setup, Communication, Direct Connections make sure the same Port Number is listed and you’ve selected the port to use.

    #4913
    Trevor Jackson

    Thanks for the reply.  To answer your questions:

    • I did check option G34 and it is set to 115200.
    • For the version of ELKRP2, I am running 2.0.38.
    • I also did download and run the special updater utility and it informed me that I was running the latest version and that no update was required.
    • I also verified that the serial port in windows (Com3) was set to 115200 and that the same was selected in the ELKRP2 software however I am still not able to get the M1EXP to communicate with my M1.

     

    #4918
    Brad Weeks

    In ElkRP2

    • Click Setup, Options, Network Adapters and use the dropdown to select the IP Address of your PC on the Local Area Network
    • When you FIND the M1XEP on the LAN is the address in the same range as your PC for example the M1XEP is 192.168.1.25 an your PC is 192.168.1.30
    • On the Account Detail Screen make sure the System URL/IP matches the M1XEP
    • Port 2601
    • Connect Non-Secure should NOT be checked
    • Try the connection again
    #4923
    Stephen Miller

    I recently went through this same scenario.  In order to lessen the number of variables, I connected directly to the M1 serial port using a terminal program (PuTTY, Hyperterminal, SecureCRT).

    From there, I was able to determine that only output from the M1 was working (ie nothing I sent to the M1 was being received) but I would see the XK ping command normally sent to the XEP by the M1.

    Because I was chasing a recent “power event” (lightning), I figured the M1 232 RX interface had suffered damage.  I ordered the 232 chip (Max Linear SP3232ECT, ~$1.35) and replaced it on the M1 board.   This fixed my problem.

    #4926
    Trevor Jackson

    Thanks,

    I’ve verified all that, same network, I can ping the M1EXP, it can be found through the ELKRP software and the M12Go software etc., I just can’t seem to communicate with it.  I’ve tried both settings (secure and non-secure) and both arrive at the same result.

    #4927
    Trevor Jackson

    I recently went through this same scenario.  In order to lessen the number of variables, I connected directly to the M1 serial port using a terminal program (PuTTY, Hyperterminal, SecureCRT).

    From there, I was able to determine that only output from the M1 was working (ie nothing I sent to the M1 was being received) but I would see the XK ping command normally sent to the XEP by the M1.

    Because I was chasing a recent “power event” (lightning), I figured the M1 232 RX interface had suffered damage.  I ordered the 232 chip (Max Linear SP3232ECT, ~$1.35) and replaced it on the M1 board.   This fixed my problem.

    Thanks! I think I’ll try connecting directly to the serial port with terminal software to see what results I get.

    #4930
    Stephen Miller

    Note that you’ll want to wait at least 30 seconds for any output on the serial port.  I think the XK heartbeat/ping command is only transmitted every 30 seconds.  I nearly gave up waiting before seeing it…

    In order to verify the RX side of the port, you should be able to transmit one of the simple serial commands using the terminal.  I typically use the version request (vn) command.

    #5138
    John Kalena

    I’m having the same problem as Trevor. I cant connect through the M1XEP. I can ping the m1xep on the network. The Elk is set to the correct vales in programming.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Scroll to Top