M1 Support Forum M1XEP Unable to Connect Via Network Connection


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #6958
    Stephen Schwarz


      My email and text notifications stopped running so I went to check the device and have not been able to connect to the M1XEP. This is an existing setup for about 10 years with an M1G and M1XEP, no new network hardware or any changes made to the configuration recently. The M1XEP is visible on the network by IP address and is pingable. It was setup to default ports, and a secure connection. The M1XEP shows up in the ElkRP software when using the find button in the M1XEP Setup. It displays the proper IP address and port number. When attempting to connect via ElkRP a windows pops up saying “Connection Error: Could not connect. Possible Reasons: The port is not forwarded through the router. The IP Address or URL is incorrect. The remote site is down.”  I have power cycled the M1XEP, Ethernet lights are flashing and LED light is solid red. Also tried connected from a second PC, but no luck.

      Tried a trace:

      12:22:30 Close_Socks: 01 = 04
      12:22:30 TCP secure connection got no response
      12:22:30 Open_Socks: 01 = 05
      12:22:30 TCP Secure connection accepted
      12:22:33 Close_Socks: 01 = 04
      12:22:33 TCP secure connection got no response
      12:22:33 Open_Socks: 01 = 05
      12:22:33 TCP Secure connection accepted
      12:22:37 Close_Socks: 01 = 04
      12:22:37 TCP secure connection got no response
      12:22:37 Open_Socks: 01 = 05
      12:22:37 TCP Secure connection accepted
      12:22:39 TCP SendUnkPkt 0AZC009900C0
      12:22:40 Close_Socks: 01 = 04
      12:22:40 TCP secure connection got no response
      12:22:40 Open_Socks: 01 = 05
      12:22:40 TCP Secure connection accepted
      12:22:43 TCP SendUnkPkt 0AZC009300C6

      Any next steps for troubleshooting?  Thanks

      Chad Faith

        I would add that I am seeing the same issue that Stephen is experiencing. I also have a M1G and an M1XEP, my system is of a similar age, installed in July 2011. My issues started over the last 24 hours. I am seeing the same information in my trace. I have tried a number of different troubleshooting steps including re-enrolling the bus modules.

        Thank you

        Brad Weeks

          Please make sure you are running the latest ElkRP2 version 2.0.40 Software:

          • Open ElkRP2 and your Account
          • Click the M1XEP Setup
          • Click Trace
          • Click Select All, click Show Setup, Click Resume,  Click Copy To Clipboard
          • Paste the data into an email and forward to techsupport@elkproducts.com with a brief note

          I would also suggest checking to make sure the M1XEP is running Firmware 2.0.34 or later using the Special M1XEP 2.0.34 Updater Utility at https://www.elkproducts.com/elk-m1xep-and-windows-compatibility/

          If running ElKRP2 2.0.40 and the M1XEP is at 2.0.34 or Later try the following:

          • Open ElkRP2 and your account
          • Click the M1XEP Setup and Find
          • Make sure the M1XEP is found and the IP is compatible with the Local Area Network
          • From the ElkRP2 Toolbar click Setup, Options, Network Adapters and within the dropdown you should see the IP Address of your PC on the Local Area Network
          • The IP of the M1XEP and the IP of your PC should be compatible on the LAN — For example M1XEP, PCs IP
          • On the Account Detail Screen of ElkRP2 System URL/IP should be the M1XEP
          • Port 2601
          • the “Connect Non-Secure” Option should NOT be checked

          With the M1XEP Trace running (make sure to click Resume) try the connection again and if it fails email a copy of the M1XEP Track showing all setup information and data in the trace window to techsupport@elkproducts.com with a brief note.



          Stephen Schwarz

            Hi again, I was using ElkRP2 software 2.0.40 and the M1XEP is at 2.0.34. I ended up unplugging the RS232 cable from the M1XEP, then I unplugged the backup battery and power cycled the M1G. After plugging the M1XEP back in and plugging the power back in, the M1XEP came back to normal operation. I was able to connect from the ELKrp2 software and notifications started to send again.

            Thank you

            Chad Faith

              As a follow-up to my post in this topic. I found that the root cause was the ELK integration that I am running on my Home Assistant instance. From what I can gather, a recent update to openSSL caused an bug to appear in the most recent version of Home Assistant. The bug resulted in a constant stream of connect tries that took down the M1XEP. I disabled my ELK integration in Home Assistant and thing are working again. If anyone would like more info on the issue: https://github.com/home-assistant/core/issues/94198

              Thank you

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.
            Scroll to Top